Przygody z Lenovo G510 – problemy LVDS i inne…

Oczywiście jak zwykle projekt jest już przeterminowany, gdyż sama naprawa odbywała się w październiku. Aczkolwiek na tym blogu spóźnienia i notoryczne lenistwo nie powinno już nikogo dziwić 😁 Ale do rzeczy…
Odezwał się do mnie mój wujek z prośbą o naprawę laptopa który cierpiał na problem znikającego obrazu…

Diagnostyki czas…

Po odebraniu maszynki zabrałem się za diagnostykę.
Na początek należało sprawdzić jak wygląda stan sprzętu.
Faktycznie po podłączeniu ładowarki i włączeniu laptopa zero obrazu oraz podświetlenia. Nawet świecąc latarką w matrycę nie dało się zauważyć śladów obrazu.
Na zewnętrznym monitorze obraz się pojawił, co potwierdziło że grafika i jej RAM są sprawne, choć bardzo dziwne wydało mi się że brakuje naraz podświetlenia i sygnału wideo dla matrycy, więc od razu założyłem uszkodzenie elektroniki sterującej matrycą…

Po rozebraniu klapy

Rozpocząłem od demontażu pokrywy G510. Klapa zamknięta była na zatrzaski co wymagało użycia cienkiego narzędzia do otwierania; Można w takim przypadku użyć również choćby karty bankomatowej czy coś w tym rodzaju. Ja miałem dedykowane narzędzie do otwierania tego typu sprzętu (narzędzie zwane „spudger„).
Po odkręceniu matrycy z obudowy położyłem ją na kadłubie laptopa aby mieć dostęp do elektroniki sterującej. Zdjąłem częściowo folie ochraniającą elektronikę, włączyłem laptopa i zacząłem multimetrem sprawdzać obecność napięć oraz sygnałów.
Ostatecznie po kilkunastu minutach sprawdzania multimetrem trochę „na ślepo” wyniki były następujące – główne napięcie zasilania Vccs nieobecne; napięcie LED_Vccs obecne i poprawne.
Wniosek nasuwał się sam – laptop nie generuje napięcia zasilania matrycy lub nie dochodzi ono do samej matrycy więc rozpocząłem poszukiwania problemu od strony płyty głównej.

Ale…

Rozebrałem kadłub G510 aby dostać się do złącza LVDS w celu sprawdzenia czy napięcia, których brakuje na elektronice matrycy, są obecne na jej wejściu. Niestety złącze jest na tyle zminiaturyzowane że gmeranie sondami multimetru przy tak drobnych pinach jest sztuką. Włączyłem więc laptopa i gmeram… Skutek?
Przypadkowo zwarte dwa piny, magiczny dym. Szybkie wyłączenie sprzętu z zasilania. Ocena uszkodzeń.
Przez zwarcie pinu z masą – spalony tranzystor MOSFET LP2301ALT1G oznaczony jako Q83.
Szybkie sprawdzenie schematu płyty głównej laptopa (Compal LA-9641P R. 1.0) i już wiadomo – tranzystor steruje zasilaniem kamerki – w przypadku gdy nie jest używana, system odłącza kamerce zasilanie poprzez ten tranzystor.
Żadna poważna usterka bo przecież kamerka nikogo nie obchodzi 😆

Płyta główna – Compal LA-9641P

Napraw czas

Podczas prób mierzenia napięć na złączu LVDS gdy poruszyłem matrycą i przewodem nagle obraz na ekranie się pojawił. W tym momencie jasnym dla mnie było że problemem jest uszkodzona taśma matrycy.
Niedługo później pojawił się kolejny problem – laptop przestał się włączać i wpadał w bootloop. Problemem okazały się styki modułu pamięci RAM które były z jakiegoś powodu zabrudzone (po kilkukrotnym wyciąganiu modułów wcześniej). Po wyczyszczeniu slotu i pamięci denaturatem laptop znów zadziałał.

Płyta główna – Compal LA-9641P

Wymiana MOSFETu

Jako że miałem już płytę na stole to warto byłoby przyjrzeć się uszkodzeniu zasilania kamerki. Wygooglowałem więc model tranzystora, który został spalony, korzystając ze schematu płyty i zacząłem szukać zamiennika na płytach które posiadałem na stosie do złomowania.
Znalazłem płytę Quanta ZR1 DA0ZR1MB6D1 a na niej pierwszy lepszy pasujący wielkością tranzystor – AO3403. Porównując parametry obu tranzystorów wyszło że zamiennik jest projektowany do pracy w wyższych obciążeniach, lecz nie ma to w tym wypadku znaczenia.

Usunąłem uszkodzony MOSFET miażdżąc go kombinerkami i usuwając lutownicą resztki z padów. Wyczyściłem pady z cyny z pomocą plecionki, nałożyłem ciut świeżej cyny.
Następnie wylutowałem hotairem nowy tranzystor z płyty-dawcy. Położyłem go na naprawianej płycie i dotykając lutownicą po kolei pinów tranzystora, przylutowałem go do PCB.
Oczyściłem okolice i tranzystor z topnika, podłączyłem laptopa do zasilania i monitora zewnętrznego. Uruchomiłem system, włączyłem aplikację Aparat z systemu Windows 8 aby aktywować kamerę i sprawdziłem obecność napięcia na wyjściu tranzystora – 3.3V więc wszystko działa idealnie.
Ostatecznie zostało mi czekać na nową, zamówioną taśmę LVDS.

Przewód otrzymany!

I na tym się problemy nie zakończyły. Bardzo szybko się okazało że zamówiony przewód nie pasuje do posiadanego na warsztacie modelu laptopa.
Wyszło na to że jeden model G510 posiada dwie różne wersje płyt głównych i co za tym idzie – taśm LVDS.
Po jakimś czasie trwania wojenki ze sprzedającym, zwrócił on pieniądze a taśmę odesłałem po czym zamówiłem u innego sprzedawcy na Allegro nową, poprawną taśmę.
Gdy ją otrzymałem przystąpiłem do ponownego demontażu sprzętu oraz usunięcia starej taśmy i montażu nowej. Przy okazji montażu sprzętu wymienione zostały pasty termoprzewodzące oraz wyczyszczono całe wnętrze dokładnie.
Gdy laptop został złożony, wyczyściłem również dokładnie jego obudowę. Przeszedłem więc do testów.

Testy!

Naprawy i konserwacje zakończone więc czas sprawdzić czy wszystko śmiga jak należy.
Podłączyłem więc baterię, uruchomiłem G510 i czekamy…
Na szczęście obraz pojawił się – nie miga, nie zanika. Wszystko działa idealnie.
Po uruchomieniu się systemu sprawdziłem również poprawność działania kamerki – również bez zastrzeżeń.

Sukces!

Podsumowanie

Cóż, przesadziłem ciut ze swoimi wstępnymi podejrzeniami. A wpadki… zdarzają się najlepszym. Na szczęście uszkodzenia nie były poważne i dało się je bardzo prosto naprawić.
Koniec końców sprzęt działa idealnie a rodzinka jest zadowolona.
Dzięki za czytanie! Zachęcam co komentowania i udostępniania!